MgServerExtensions

MapGuide Server Extensions
MgServerExtensions Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AfterGetTileEventArgs | Provides data for AfterGetTile event.
Public class | BeforeGetTileEventArgs | Provides data for BeforeGetTile event.
Public class | DocumentField | Represents a single Adobe PDF document template field. DocumentFields provides access to all fields defined within a template.
Public class | DocumentFields | Represents Adobe PDF template fields collection used for populating form with data. Single field within collection is accessible either via field index or a field name.
Public class | Documents | Provides functionality for creating Adobe PDF documents based on ready-made document and data templates (forms). This class is not dependant on MapGuide Server.
Public class | Features | Class responsible for feature data management. Feature data represents resources stored in a file or a database.
Public class | Resources | Class responsible for either library-based or session-based repository data management.
Public class | Server | Represents a base class for accessing MapGuide Server services and resources. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | Tiling | Class responsible for rendering maps into images. It also supports generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer.

Delegates

 | Delegate | Description
NestedPublic delegate | Tiling.AfterGetTileEventHandler |
NestedPublic delegate | Tiling.BeforeGetTileEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GeometryTypes | Enumerated geometry types used by feature sources.
Public enumeration | SpatialOperations | Enumerates methods to test spatial relationships.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.

Send comments on this topic.

Copyright ©2007 by Maksim Sestic, INOVA informaticki inzenjering. All Rights Reserved.


AfterGetTileEventArgs Class

AfterGetTileEventArgs Class
See Also Example Members
[image]

Provides data for AfterGetTile event.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class AfterGetTileEventArgs
Inherits EventArgs
C#
public class AfterGetTileEventArgs : EventArgs
C++
ref class AfterGetTileEventArgs : EventArgs
J#
public class AfterGetTileEventArgs extends EventArgs
JScript
public class AfterGetTileEventArgs extends EventArgs

Remarks

AfterGetTile event occurs after each call to GetTile function within batch tiling operation being run via CreateCache method.

Inheritance Hierarchy

System.Object
System.EventArgs
MgServerExtensions.AfterGetTileEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AfterGetTileEventArgs Members
MgServerExtensions Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.

Send comments on this topic.

Copyright ©2007 by Maksim Sestic, INOVA informaticki inzenjering. All Rights Reserved.

Generated from assembly MgServerExtensions [1.0.2863.21225]


AfterGetTileEventArgs Members

AfterGetTileEventArgs Members
See Also Example Constructors Properties Methods
[image]

Provides data for AfterGetTile event.

The following tables list the members exposed by AfterGetTileEventArgs.

Public Constructors

 | Name | Description
Public method | AfterGetTileEventArgs | Initializes a new instance of the AfterGetTileEventArgs class.
Top

Public Properties

 | Name | Description
Public property | Exception | Returns any MgException raised during tile processing operation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AfterGetTileEventArgs Class
MgServerExtensions Namespace


AfterGetTileEventArgs Constructor

AfterGetTileEventArgs Constructor
See Also Example
[image]

Initializes a new instance of the AfterGetTileEventArgs class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AfterGetTileEventArgs()
C++
public:
AfterGetTileEventArgs() sealed
J#
public AfterGetTileEventArgs()
JScript
public function AfterGetTileEventArgs()

See Also

AfterGetTileEventArgs Class


Properties

AfterGetTileEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Exception | Returns any MgException raised during tile processing operation.
Top

See Also

AfterGetTileEventArgs Class


Exception Property

AfterGetTileEventArgs.Exception Property
[image]

Returns any MgException raised during tile processing operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception { get; }
C++
public property Exception Exception sealed {
Exception get();
}
J#
/** property */
public Exception get_Exception();
JScript
public function get Exception() : Exception

Property Value

A MgException if tile processing operation failed, or Nothing if map tile has been processed without errors.

See Also

AfterGetTileEventArgs Class


BeforeGetTileEventArgs Class

BeforeGetTileEventArgs Class
See Also Example Members
[image]

Provides data for BeforeGetTile event.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class BeforeGetTileEventArgs
Inherits EventArgs
C#
public class BeforeGetTileEventArgs : EventArgs
C++
ref class BeforeGetTileEventArgs : EventArgs
J#
public class BeforeGetTileEventArgs extends EventArgs
JScript
public class BeforeGetTileEventArgs extends EventArgs

Remarks

BeforeGetTile event occurs before each call to GetTile function within batch tiling operation being run via CreateCache method. It also provides means to break tiling sequence and exit from current batch operation.

Inheritance Hierarchy

System.Object
System.EventArgs
MgServerExtensions.BeforeGetTileEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BeforeGetTileEventArgs Members


BeforeGetTileEventArgs Members

BeforeGetTileEventArgs Members
See Also Example Constructors Properties Methods
[image]

Provides data for BeforeGetTile event.

The following tables list the members exposed by BeforeGetTileEventArgs.

Public Constructors

 | Name | Description
Public method | BeforeGetTileEventArgs | Initializes a new instance of the BeforeGetTileEventArgs class.
Top

Public Properties

 | Name | Description
Public property | Break | If set to True via event handler, immediately breaks and exits current batch operation.
Public property | Group | Returns name of the current BaseLayer group being processed.
Public property | MapName | Returns name of the MgMap object being processed.
Public property | Scale | Returns current finite scale (not scale index) being processed within batch operation.
Public property | Tile | Returns index of the tile about to be processed within current batch operation.
Public property | TileColumn | Returns index of the current tile column being processed within batch operation.
Public property | TileColumns | Returns total number of tile columns within current batch operation.
Public property | TileRow | Returns index of the current tile row being processed within batch operation.
Public property | TileRows | Returns total number of tile rows within current batch operation.
Public property | Tiles | Returns total number of tiles within current batch operation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BeforeGetTileEventArgs Class


BeforeGetTileEventArgs Constructor

BeforeGetTileEventArgs Constructor
[image]

Initializes a new instance of the BeforeGetTileEventArgs class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BeforeGetTileEventArgs()
C++
public:
BeforeGetTileEventArgs() sealed
J#
public BeforeGetTileEventArgs()
JScript
public function BeforeGetTileEventArgs()

See Also

BeforeGetTileEventArgs Class


Properties

BeforeGetTileEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Break | If set to True via event handler, immediately breaks and exits current batch operation.
Public property | Group | Returns name of the current BaseLayer group being processed.
Public property | MapName | Returns name of the MgMap object being processed.
Public property | Scale | Returns current finite scale (not scale index) being processed within batch operation.
Public property | Tile | Returns index of the tile about to be processed within current batch operation.
Public property | TileColumn | Returns index of the current tile column being processed within batch operation.
Public property | TileColumns | Returns total number of tile columns within current batch operation.
Public property | TileRow | Returns index of the current tile row being processed within batch operation.
Public property | TileRows | Returns total number of tile rows within current batch operation.
Public property | Tiles | Returns total number of tiles within current batch operation.
Top

See Also

BeforeGetTileEventArgs Class


Break Property

BeforeGetTileEventArgs.Break Property
[image]

If set to True via event handler, immediately breaks and exits current batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Property Break As Boolean
C#
public bool Break { get; set; }
C++
public property bool Break sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Break();

/** property */
public void set_Break(bool value);
JScript
public function get Break() : bool

public function set Break(value : bool);

See Also

BeforeGetTileEventArgs Class


Group Property

BeforeGetTileEventArgs.Group Property
[image]

Returns name of the current BaseLayer group being processed.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Group As String
C#
public string Group { get; }
C++
public property string Group sealed {
String get();
}
J#
/** property */
public string get_Group();
JScript
public function get Group() : String

Property Value

Name of the current BaseLayer group being processed.

See Also

BeforeGetTileEventArgs Class


MapName Property

BeforeGetTileEventArgs.MapName Property
[image]

Returns name of the MgMap object being processed.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapName As String
C#
public string MapName { get; }
C++
public property string MapName sealed {
String get();
}
J#
/** property */
public string get_MapName();
JScript
public function get MapName() : String

Property Value

Name of the MgMap object.

See Also

BeforeGetTileEventArgs Class


Scale Property

BeforeGetTileEventArgs.Scale Property
[image]

Returns current finite scale (not scale index) being processed within batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
C#
public double Scale { get; }
C++
public property double Scale sealed {
double get();
}
J#
/** property */
public double get_Scale();
JScript
public function get Scale() : double

Property Value

Value of finite scale being processed.

See Also

BeforeGetTileEventArgs Class


Tile Property

BeforeGetTileEventArgs.Tile Property
[image]

Returns index of the tile about to be processed within current batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tile As Long
C#
public long Tile { get; }
C++
public property long Tile sealed {
__int64 get();
}
J#
/** property */
public long get_Tile();
JScript
public function get Tile() : long

Property Value

Index of the tile about to be processed.

See Also

BeforeGetTileEventArgs Class


TileColumn Property

BeforeGetTileEventArgs.TileColumn Property
[image]

Returns index of the current tile column being processed within batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TileColumn As Integer
C#
public int TileColumn { get; }
C++
public property int TileColumn sealed {
int get();
}
J#
/** property */
public int get_TileColumn();
JScript
public function get TileColumn() : int

Property Value

Index of the current tile column being processed.

See Also

BeforeGetTileEventArgs Class


TileColumns Property

BeforeGetTileEventArgs.TileColumns Property
[image]

Returns total number of tile columns within current batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TileColumns As Integer
C#
public int TileColumns { get; }
C++
public property int TileColumns sealed {
int get();
}
J#
/** property */
public int get_TileColumns();
JScript
public function get TileColumns() : int

Property Value

Total number of tile columns.

See Also

BeforeGetTileEventArgs Class


TileRow Property

BeforeGetTileEventArgs.TileRow Property
[image]

Returns index of the current tile row being processed within batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TileRow As Integer
C#
public int TileRow { get; }
C++
public property int TileRow sealed {
int get();
}
J#
/** property */
public int get_TileRow();
JScript
public function get TileRow() : int

Property Value

Index of the current tile row being processed.

See Also

BeforeGetTileEventArgs Class


TileRows Property

BeforeGetTileEventArgs.TileRows Property
[image]

Returns total number of tile rows within current batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TileRows As Integer
C#
public int TileRows { get; }
C++
public property int TileRows sealed {
int get();
}
J#
/** property */
public int get_TileRows();
JScript
public function get TileRows() : int

Property Value

Total number of tile rows.

See Also

BeforeGetTileEventArgs Class


Tiles Property

BeforeGetTileEventArgs.Tiles Property
[image]

Returns total number of tiles within current batch operation.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tiles As Long
C#
public long Tiles { get; }
C++
public property long Tiles sealed {
__int64 get();
}
J#
/** property */
public long get_Tiles();
JScript
public function get Tiles() : long

Property Value

Total number of tiles.

See Also

BeforeGetTileEventArgs Class


DocumentField Class

DocumentField Class
See Also Example Members
[image]

Represents a single Adobe PDF document template field. DocumentFields provides access to all fields defined within a template.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class DocumentField
C#
public class DocumentField
C++
ref class DocumentField
J#
public class DocumentField
JScript
public class DocumentField

Inheritance Hierarchy

System.Object
MgServerExtensions.DocumentField

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DocumentField Members


DocumentField Members

DocumentField Members
See Also Example Constructors Properties Methods
[image]

Represents a single Adobe PDF document template field. DocumentFields provides access to all fields defined within a template.

The following tables list the members exposed by DocumentField.

Public Constructors

 | Name | Description
Public method | DocumentField | Initializes a new instance of the DocumentField class.
Top

Public Properties

 | Name | Description
Public property | ImageURL | Gets or sets URL to an image.
Public property | Name | Gets or sets unique field name found in the form.
Public property | Value | Gets or sets form field alphanumeric value.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DocumentField Class


DocumentField Constructor

DocumentField Constructor
[image]

Initializes a new instance of the DocumentField class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DocumentField()
C++
public:
DocumentField() sealed
J#
public DocumentField()
JScript
public function DocumentField()

See Also

DocumentField Class


Properties

DocumentField Properties
[image]

Public Properties

 | Name | Description
Public property | ImageURL | Gets or sets URL to an image.
Public property | Name | Gets or sets unique field name found in the form.
Public property | Value | Gets or sets form field alphanumeric value.
Top

See Also

DocumentField Class


ImageURL Property

DocumentField.ImageURL Property
[image]

Gets or sets URL to an image.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageURL As String
C#
public string ImageURL { get; set; }
C++
public property string ImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageURL();

/** property */
public void set_ImageURL(string value);
JScript
public function get ImageURL() : String

public function set ImageURL(value : String);

See Also

DocumentField Class


Name Property

DocumentField.Name Property
[image]

Gets or sets unique field name found in the form.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DocumentField Class


Value Property

DocumentField.Value Property
[image]

Gets or sets form field alphanumeric value.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

DocumentField Class


DocumentFields Class

DocumentFields Class
See Also Example Members
[image]

Represents Adobe PDF template fields collection used for populating form with data. Single field within collection is accessible either via field index or a field name.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class DocumentFields
Inherits KeyedCollection(Of String, DocumentField)
C#
public class DocumentFields : KeyedCollection<string, DocumentField>
C++
ref class DocumentFields : KeyedCollection<string, DocumentField>
J#
public class DocumentFields extends KeyedCollection<string, DocumentField>
JScript
public class DocumentFields extends KeyedCollection<string, DocumentField>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
MgServerExtensions.DocumentFields

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DocumentFields Members


DocumentFields Members

DocumentFields Members
See Also Example Constructors Properties Methods
[image]

Represents Adobe PDF template fields collection used for populating form with data. Single field within collection is accessible either via field index or a field name.

The following tables list the members exposed by DocumentFields.

Public Constructors

 | Name | Description
Public method | DocumentFields | Initializes a new instance of the DocumentFields class.
Top

Public Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (inherited from KeyedCollection)
Public property | Count | Gets the number of elements actually contained in the Collection. (inherited from Collection)
Public property | Item | Overloaded. Gets the element with the specified key. (inherited from KeyedCollection)
Top

Protected Properties

 | Name | Description
Family property | Dictionary | Gets the lookup dictionary of the KeyedCollection. (inherited from KeyedCollection)
Family property | Items | Gets a List wrapper around the Collection. (inherited from Collection)
Top

Public Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection. (inherited from Collection)
Public method | Clear | Removes all elements from the Collection. (inherited from Collection)
Public method | Contains | Overloaded. Determines whether an element is in the Collection. (inherited from KeyedCollection)
Public method | CopyTo | Copies the entire Collection to a compatible one-dimensional Array, starting at the specified index of the target array. (inherited from Collection)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection. (inherited from Collection)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (inherited from Collection)
Public method | Insert | Inserts an element into the Collection at the specified index. (inherited from Collection)
 | ReadXml | Deserializes DocumentFields collection from a file.
Public method | Remove | Overloaded. Removes the first occurrence of a specific object from the Collection. (inherited from KeyedCollection)
Public method | RemoveAt | Removes the element at the specified index of the Collection. (inherited from Collection)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteXml | Serializes DocumentFields collection into the file.
Top

Protected Methods

 | Name | Description
Family method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (inherited from KeyedCollection)
Family method | ClearItems | Removes all elements from the KeyedCollection. (inherited from KeyedCollection)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetKeyForItem | Overridden.
Family method | InsertItem | Inserts an element into the KeyedCollection at the specified index. (inherited from KeyedCollection)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RemoveItem | Removes the element at the specified index of the KeyedCollection. (inherited from KeyedCollection)
Family method | SetItem | Replaces the item at the specified index with the specified item. (inherited from KeyedCollection)
Top

See Also

DocumentFields Class


DocumentFields Constructor

DocumentFields Constructor
[image]

Initializes a new instance of the DocumentFields class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DocumentFields()
C++
public:
DocumentFields() sealed
J#
public DocumentFields()
JScript
public function DocumentFields()

See Also

DocumentFields Class


Methods

DocumentFields Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection. (inherited from Collection)
Public method | Clear | Removes all elements from the Collection. (inherited from Collection)
Public method | Contains | Overloaded. Determines whether an element is in the Collection. (inherited from KeyedCollection)
Public method | CopyTo | Copies the entire Collection to a compatible one-dimensional Array, starting at the specified index of the target array. (inherited from Collection)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection. (inherited from Collection)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (inherited from Collection)
Public method | Insert | Inserts an element into the Collection at the specified index. (inherited from Collection)
 | ReadXml | Deserializes DocumentFields collection from a file.
Public method | Remove | Overloaded. Removes the first occurrence of a specific object from the Collection. (inherited from KeyedCollection)
Public method | RemoveAt | Removes the element at the specified index of the Collection. (inherited from Collection)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteXml | Serializes DocumentFields collection into the file.
Top

Protected Methods

 | Name | Description
Family method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (inherited from KeyedCollection)
Family method | ClearItems | Removes all elements from the KeyedCollection. (inherited from KeyedCollection)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetKeyForItem | Overridden.
Family method | InsertItem | Inserts an element into the KeyedCollection at the specified index. (inherited from KeyedCollection)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RemoveItem | Removes the element at the specified index of the KeyedCollection. (inherited from KeyedCollection)
Family method | SetItem | Replaces the item at the specified index with the specified item. (inherited from KeyedCollection)
Top

See Also

DocumentFields Class


GetKeyForItem Method

DocumentFields.GetKeyForItem Method
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetKeyForItem( _
ByVal item As DocumentField _
) As String
C#
protected override string GetKeyForItem(
DocumentField item
)
C++
protected:
virtual String GetKeyForItem(
DocumentField item
) override
J#
protected override string GetKeyForItem(
DocumentField item
)
JScript
protected override function GetKeyForItem(
item : DocumentField
) : String

See Also

DocumentFields Class


ReadXml Method

DocumentFields.ReadXml Method
[image]

Deserializes DocumentFields collection from a file.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadXml( _
ByVal fileName As String _
) As DocumentFields
C#
public static DocumentFields ReadXml(
string fileName
)
C++
public:
static DocumentFields ReadXml(
String fileName
)
J#
public static DocumentFields ReadXml(
string fileName
)
JScript
public static function ReadXml(
fileName : String
) : DocumentFields

Parameters

fileName
Path to the existing XML file.

Return Value

A DocumentFields collection.

See Also

DocumentFields Class


WriteXml Method

DocumentFields.WriteXml Method
[image]

Serializes DocumentFields collection into the file.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml( _
ByVal fileName As String _
)
C#
public void WriteXml(
string fileName
)
C++
public:
void WriteXml(
String fileName
) sealed
J#
public void WriteXml(
string fileName
)
JScript
public function WriteXml(
fileName : String
)

Parameters

fileName
Path to the XML file to create.

See Also

DocumentFields Class


Documents Class

Documents Class
See Also Example Members
[image]

Provides functionality for creating Adobe PDF documents based on ready-made document and data templates (forms). This class is not dependant on MapGuide Server.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class Documents
C#
public class Documents
C++
ref class Documents
J#
public class Documents
JScript
public class Documents

Inheritance Hierarchy

System.Object
MgServerExtensions.Documents

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Documents Members


Documents Members

Documents Members
See Also Example Constructors Methods
[image]

Provides functionality for creating Adobe PDF documents based on ready-made document and data templates (forms). This class is not dependant on MapGuide Server.

The following tables list the members exposed by Documents.

Public Constructors

 | Name | Description
Public method | Documents | Initializes a new instance of the Documents class.
Top

Public Methods

 | Name | Description
Public method | CreateFromTemplate | Creates flattened Adobe PDF file based on given PDF form and XML data template containing actual form data. Flattened PDF files cannot be changed any more.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Documents Class


Documents Constructor

Documents Constructor
[image]

Initializes a new instance of the Documents class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Documents()
C++
public:
Documents() sealed
J#
public Documents()
JScript
public function Documents()

See Also

Documents Class


Methods

Documents Methods
[image]

Public Methods

 | Name | Description
Public method | CreateFromTemplate | Creates flattened Adobe PDF file based on given PDF form and XML data template containing actual form data. Flattened PDF files cannot be changed any more.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Documents Class


CreateFromTemplate Method

Documents.CreateFromTemplate Method
[image]

Creates flattened Adobe PDF file based on given PDF form and XML data template containing actual form data. Flattened PDF files cannot be changed any more.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateFromTemplate( _
ByVal inFileName As String, _
ByVal inXmlFileName As String, _
ByVal outFileName As String _
)
C#
public void CreateFromTemplate(
string inFileName,
string inXmlFileName,
string outFileName
)
C++
public:
void CreateFromTemplate(
String inFileName,
String inXmlFileName,
String outFileName
) sealed
J#
public void CreateFromTemplate(
string inFileName,
string inXmlFileName,
string outFileName
)
JScript
public function CreateFromTemplate(
inFileName : String,
inXmlFileName : String,
outFileName : String
)

Parameters

inFileName
Path to PDF form file (document template).
inXmlFileName
Path to XML data template file.
outFileName
Path to resulting flattened PDF file.

See Also

Documents Class


Features Class

Features Class
See Also Example Members
[image]

Class responsible for feature data management. Feature data represents resources stored in a file or a database.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class Features
Inherits Server
C#
public class Features : Server
C++
ref class Features : Server
J#
public class Features extends Server
JScript
public class Features extends Server

Remarks

Within a single feature source there may be one or more feature classes. A feature class describes a subset of the features in the feature source. In many cases, there is one feature class for each feature source. For example, there may be a Roads feature class in the RoadCenterLines feature source.

A feature class contains one or more features. Each feature has a geometry that defines spatial representation of the feature. Features will also generally have one or more properties that provide additional information. For example, a feature class containing road data may have properties for the road name and the number of lanes. Feature properties can be of different types, like strings, integers, and floating point numbers. Possible types are defined in the class MgPropertyType.

Inheritance Hierarchy

System.Object
MgServerExtensions.Server
MgServerExtensions.Features

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Features Members


Features Members

Features Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Class responsible for feature data management. Feature data represents resources stored in a file or a database.

The following tables list the members exposed by Features.

Public Constructors

Name | Description
Features | Overloaded. Initializes a new instance of the Features class.
Top

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgFeatureService service responsible for feature data management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFeatureNameFromResource | Returns FeatureSource name for given resource name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetResourceFromFeatureName | Returns MgResourceIdentifier according to given FeatureSource name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | SelectSpatial | Overloaded.
Public method | SelectString | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Features | Overloaded. Initializes a new instance of the Features class.
Top

See Also

Features Class


Features Constructor

Features Constructor

Initializes a new instance of the Features class.

Overload List

 | Name | Description
Public method | Features | Initializes a new instance of the Features class.
Public method | Features (Server) | Initializes a new instance of the Features class, based on already instantiated object derived from Server class.
Public method | Features (String) | Initializes a new instance of the Features class, based on Session identifier obtained from client already running existing MapGuide session.

See Also

Features Class


Features Constructor ()

Features Constructor ()
See Also Example
[image]

Initializes a new instance of the Features class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Features()
C++
public:
Features() sealed
J#
public Features()
JScript
public function Features()

See Also

Features Class
Features Constructor Overload List


Features Constructor (Server)

Features Constructor (Server)
See Also Example
[image]

Initializes a new instance of the Features class, based on already instantiated object derived from Server class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal other As Server _
)
C#
public Features(
Server other
)
C++
public:
Features(
Server other
) sealed
J#
public Features(
Server other
)
JScript
public function Features(
other : Server
)

Parameters

other
Any object derived from Server class.

See Also

Features Class
Features Constructor Overload List


Features Constructor (String)

Features Constructor (String)
See Also Example
[image]

Initializes a new instance of the Features class, based on Session identifier obtained from client already running existing MapGuide session.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal sessionId As String _
)
C#
public Features(
string sessionId
)
C++
public:
Features(
String sessionId
) sealed
J#
public Features(
string sessionId
)
JScript
public function Features(
sessionId : String
)

Parameters

sessionId
A Session identifier.

See Also

Features Class
Features Constructor Overload List


Properties

Features Properties
[image]

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgFeatureService service responsible for feature data management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

See Also

Features Class


Service Property

Features.Service Property
[image]

Returns MgFeatureService service responsible for feature data management.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Service As MgFeatureService
C#
public MgFeatureService Service { get; }
C++
public property MgFeatureService Service sealed {
MgFeatureService get();
}
J#
/** property */
public MgFeatureService get_Service();
JScript
public function get Service() : MgFeatureService

Property Value

A MgFeatureService object.

Remarks

A service performs a particular set of MapGuide Server related functions. Feature service manages feature sources found in the repository. A feature source is a resource that contains a set of related features, stored in a file or database.

See Also

Features Class


Methods

Features Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFeatureNameFromResource | Returns FeatureSource name for given resource name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetResourceFromFeatureName | Returns MgResourceIdentifier according to given FeatureSource name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | SelectSpatial | Overloaded.
Public method | SelectString | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Features Class


Dispose Method

Features.Dispose Method

Frees unmanaged resources referenced by this class.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden.
Public method | Dispose | Frees unmanaged resources referenced by this class. (inherited from Server)

See Also

Features Class


Dispose Method (Boolean)

Features.Dispose Method (Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

See Also

Features Class
Features.Dispose Overload List


GetFeatureNameFromResource Method

Features.GetFeatureNameFromResource Method
[image]

Returns FeatureSource name for given resource name.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFeatureNameFromResource( _
ByVal resource As String _
) As String
C#
public string GetFeatureNameFromResource(
string resource
)
C++
public:
String GetFeatureNameFromResource(
String resource
) sealed
J#
public string GetFeatureNameFromResource(
string resource
)
JScript
public function GetFeatureNameFromResource(
resource : String
) : String

Parameters

resource
Name of the FeatureSource resource identifyer.

Return Value

Name of the FeatureSource.

See Also

Features Class


GetResourceFromFeatureName Method

Features.GetResourceFromFeatureName Method
[image]

Returns MgResourceIdentifier according to given FeatureSource name.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetResourceFromFeatureName( _
ByVal name As String _
) As MgResourceIdentifier
C#
public MgResourceIdentifier GetResourceFromFeatureName(
string name
)
C++
public:
MgResourceIdentifier GetResourceFromFeatureName(
String name
) sealed
J#
public MgResourceIdentifier GetResourceFromFeatureName(
string name
)
JScript
public function GetResourceFromFeatureName(
name : String
) : MgResourceIdentifier

Parameters

name
Name of the FeatureSource.

Return Value

A MgResourceIdentifier object

See Also

Features Class


SelectSpatial Method

Features.SelectSpatial Method

Overload List

 | Name | Description
Public method | SelectSpatial (String, String, String) |
Public method | SelectSpatial (String, String, String, MgGeometry, SpatialOperations) |
Public method | SelectSpatial (String, String, String, Double, Double, Double, SpatialOperations) |
Public method | SelectSpatial (String, String, String, String, MgGeometry, SpatialOperations) |
Public method | SelectSpatial (String, String, String, String, Double, Double, Double, SpatialOperations) |

See Also

Features Class


SelectSpatial Method (String, String, String)

Features.SelectSpatial Method (String, String, String)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectSpatial( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String _
) As MgGeometryCollection
C#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName
)
C++
public:
MgGeometryCollection SelectSpatial(
String featureSourceName,
String className,
String geometricPropertyName
) sealed
J#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName
)
JScript
public function SelectSpatial(
featureSourceName : String,
className : String,
geometricPropertyName : String
) : MgGeometryCollection

See Also

Features Class
Features.SelectSpatial Overload List


SelectSpatial Method (String, String, String, MgGeometry, SpatialOperations)

Features.SelectSpatial Method (String, String, String, MgGeometry, SpatialOperations)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectSpatial( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String, _
ByVal geometryFilter As MgGeometry, _
ByVal spatialOperation As SpatialOperations _
) As MgGeometryCollection
C#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
)
C++
public:
MgGeometryCollection SelectSpatial(
String featureSourceName,
String className,
String geometricPropertyName,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
) sealed
J#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
)
JScript
public function SelectSpatial(
featureSourceName : String,
className : String,
geometricPropertyName : String,
geometryFilter : MgGeometry,
spatialOperation : SpatialOperations
) : MgGeometryCollection

See Also

Features Class
Features.SelectSpatial Overload List


SelectSpatial Method (String, String, String, Double, Double, Double, SpatialOperations)

Features.SelectSpatial Method (String, String, String, Double, Double, Double, SpatialOperations)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectSpatial( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal distance As Double, _
ByVal spatialOperation As SpatialOperations _
) As MgGeometryCollection
C#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
double x,
double y,
double distance,
SpatialOperations spatialOperation
)
C++
public:
MgGeometryCollection SelectSpatial(
String featureSourceName,
String className,
String geometricPropertyName,
double x,
double y,
double distance,
SpatialOperations spatialOperation
) sealed
J#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
double x,
double y,
double distance,
SpatialOperations spatialOperation
)
JScript
public function SelectSpatial(
featureSourceName : String,
className : String,
geometricPropertyName : String,
x : double,
y : double,
distance : double,
spatialOperation : SpatialOperations
) : MgGeometryCollection

See Also

Features Class
Features.SelectSpatial Overload List


SelectSpatial Method (String, String, String, String, MgGeometry, SpatialOperations)

Features.SelectSpatial Method (String, String, String, String, MgGeometry, SpatialOperations)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectSpatial( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String, _
ByVal valueFilter As String, _
ByVal geometryFilter As MgGeometry, _
ByVal spatialOperation As SpatialOperations _
) As MgGeometryCollection
C#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
string valueFilter,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
)
C++
public:
MgGeometryCollection SelectSpatial(
String featureSourceName,
String className,
String geometricPropertyName,
String valueFilter,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
) sealed
J#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
string valueFilter,
MgGeometry geometryFilter,
SpatialOperations spatialOperation
)
JScript
public function SelectSpatial(
featureSourceName : String,
className : String,
geometricPropertyName : String,
valueFilter : String,
geometryFilter : MgGeometry,
spatialOperation : SpatialOperations
) : MgGeometryCollection

See Also

Features Class
Features.SelectSpatial Overload List


SelectSpatial Method (String, String, String, String, Double, Double, Double, SpatialOperations)

Features.SelectSpatial Method (String, String, String, String, Double, Double, Double, SpatialOperations)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectSpatial( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String, _
ByVal valueFilter As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal distance As Double, _
ByVal spatialOperation As SpatialOperations _
) As MgGeometryCollection
C#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
string valueFilter,
double x,
double y,
double distance,
SpatialOperations spatialOperation
)
C++
public:
MgGeometryCollection SelectSpatial(
String featureSourceName,
String className,
String geometricPropertyName,
String valueFilter,
double x,
double y,
double distance,
SpatialOperations spatialOperation
) sealed
J#
public MgGeometryCollection SelectSpatial(
string featureSourceName,
string className,
string geometricPropertyName,
string valueFilter,
double x,
double y,
double distance,
SpatialOperations spatialOperation
)
JScript
public function SelectSpatial(
featureSourceName : String,
className : String,
geometricPropertyName : String,
valueFilter : String,
x : double,
y : double,
distance : double,
spatialOperation : SpatialOperations
) : MgGeometryCollection

See Also

Features Class
Features.SelectSpatial Overload List


SelectString Method

Features.SelectString Method

Overload List

 | Name | Description
Public method | SelectString (String, String, String, Boolean, Boolean) |
Public method | SelectString (String, String, String, String, Boolean, Boolean) |
Public method | SelectString (String, String, String, String, String, MgGeometry, Double, SpatialOperations, Boolean, Boolean) |

See Also

Features Class


SelectString Method (String, String, String, Boolean, Boolean)

Features.SelectString Method (String, String, String, Boolean, Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectString( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal propertyName As String, _
ByVal isGrouped As Boolean, _
ByVal isOrdered As Boolean _
) As String()
C#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
bool isGrouped,
bool isOrdered
)
C++
public:
array<String>^ SelectString(
String featureSourceName,
String className,
String propertyName,
bool isGrouped,
bool isOrdered
) sealed
J#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
bool isGrouped,
bool isOrdered
)
JScript
public function SelectString(
featureSourceName : String,
className : String,
propertyName : String,
isGrouped : bool,
isOrdered : bool
) : String[]

See Also

Features Class
Features.SelectString Overload List


SelectString Method (String, String, String, String, Boolean, Boolean)

Features.SelectString Method (String, String, String, String, Boolean, Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectString( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal propertyName As String, _
ByVal valueFilter As String, _
ByVal isGrouped As Boolean, _
ByVal isOrdered As Boolean _
) As String()
C#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
bool isGrouped,
bool isOrdered
)
C++
public:
array<String>^ SelectString(
String featureSourceName,
String className,
String propertyName,
String valueFilter,
bool isGrouped,
bool isOrdered
) sealed
J#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
bool isGrouped,
bool isOrdered
)
JScript
public function SelectString(
featureSourceName : String,
className : String,
propertyName : String,
valueFilter : String,
isGrouped : bool,
isOrdered : bool
) : String[]

See Also

Features Class
Features.SelectString Overload List


SelectString Method (String, String, String, String, String, MgGeometry, Double, SpatialOperations, Boolean, Boolean)

Features.SelectString Method (String, String, String, String, String, MgGeometry, Double, SpatialOperations, Boolean, Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectString( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal propertyName As String, _
ByVal valueFilter As String, _
ByVal geometricPropertyName As String, _
ByVal geometryFilter As MgGeometry, _
ByVal distance As Double, _
ByVal spatialOperation As SpatialOperations, _
ByVal isGrouped As Boolean, _
ByVal isOrdered As Boolean _
) As String()
C#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
string geometricPropertyName,
MgGeometry geometryFilter,
double distance,
SpatialOperations spatialOperation,
bool isGrouped,
bool isOrdered
)
C++
public:
array<String>^ SelectString(
String featureSourceName,
String className,
String propertyName,
String valueFilter,
String geometricPropertyName,
MgGeometry geometryFilter,
double distance,
SpatialOperations spatialOperation,
bool isGrouped,
bool isOrdered
) sealed
J#
public string[] SelectString(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
string geometricPropertyName,
MgGeometry geometryFilter,
double distance,
SpatialOperations spatialOperation,
bool isGrouped,
bool isOrdered
)
JScript
public function SelectString(
featureSourceName : String,
className : String,
propertyName : String,
valueFilter : String,
geometricPropertyName : String,
geometryFilter : MgGeometry,
distance : double,
spatialOperation : SpatialOperations,
isGrouped : bool,
isOrdered : bool
) : String[]

See Also

Features Class
Features.SelectString Overload List


GeometryTypes Enumeration

GeometryTypes Enumeration
[image]

Enumerated geometry types used by feature sources.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Enum GeometryTypes
C#
public enum GeometryTypes
C++
public enum class GeometryTypes
J#
public enum GeometryTypes
JScript
public enum GeometryTypes

Members

Member Name | Description
Point | A single point.
LineString | Series of connected line segments.
Polygon | A polygon with sides formed from linear rings. Linear ring is a line string representation where line string's first and last point in the coordinate sequence must be equal. Either orientation of the ring is allowed. A valid ring must not self-intersect.
MultiPoint | Collection of points.
MultiLineString | Collection of line strings.
MultiPolygon | Collection of polygons.
MultiGeometry | Collection of simple geometry objects of any type.
CurveString | Series of connected curve segments. The curve segments are circular arcs defined by a start point, an end point, and a control point.
CurvePolygon | A polygon with sides formed from curve strings.
MultiCurveString | Collection of curve strings.
MultiCurvePolygon | Collection of curve polygons.

See Also


Resources Class

Resources Class
See Also Example Members
[image]

Class responsible for either library-based or session-based repository data management.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class Resources
Inherits Server
C#
public class Resources : Server
C++
ref class Resources : Server
J#
public class Resources extends Server
JScript
public class Resources extends Server

Remarks

A resource Repository stores all the files and configuration information used by MapGuide.

There are two types of repository: library and session. The library is used for persistent storage. It corresponds to what is shown in the Site Explorer when you use the Studio application. There may also be session repositories. These hold data only for the user's current session, and are automatically deleted by the MapGuide server if they have not been used for a certain length of time.

If this class gets instantiated without session identifier, it uses library resources as defined within MgServerExtensions.config file. Otherwise, it uses session resources based on existing MapGuide credentials for a client who originally established a session.

Inheritance Hierarchy

System.Object
MgServerExtensions.Server
MgServerExtensions.Resources

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Resources Members


Resources Members

Resources Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Class responsible for either library-based or session-based repository data management.

The following tables list the members exposed by Resources.

Public Constructors

Name | Description
Resources | Overloaded. Initializes a new instance of the Resources class.
Top

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Maps | Returns MgMapCollection collection of objects containing MgMap instances found within underlying Repository.
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgResourceService service responsible for repository data management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseLayerGroupNames | Returns array of strings containing base layer names found within given MgMap object. If there are no base layers found in map function returns empty array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMapNameFromResource | Returns MapDefinition name for given resource name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Resources | Overloaded. Initializes a new instance of the Resources class.
Top

See Also

Resources Class


Resources Constructor

Resources Constructor

Initializes a new instance of the Resources class.

Overload List

 | Name | Description
Public method | Resources | Initializes a new instance of the Resources class.
Public method | Resources (Server) | Initializes a new instance of the Resources class, based on already instantiated object derived from Server class.
Public method | Resources (String) | Initializes a new instance of the Resources class, based on Session identifier obtained from client already running existing MapGuide session.

See Also

Resources Class


Resources Constructor ()

Resources Constructor ()
See Also Example
[image]

Initializes a new instance of the Resources class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Resources()
C++
public:
Resources() sealed
J#
public Resources()
JScript
public function Resources()

See Also

Resources Class
Resources Constructor Overload List


Resources Constructor (Server)

Resources Constructor (Server)
See Also Example
[image]

Initializes a new instance of the Resources class, based on already instantiated object derived from Server class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal other As Server _
)
C#
public Resources(
Server other
)
C++
public:
Resources(
Server other
) sealed
J#
public Resources(
Server other
)
JScript
public function Resources(
other : Server
)

Parameters

other
Any object derived from Server class.

See Also

Resources Class
Resources Constructor Overload List


Resources Constructor (String)

Resources Constructor (String)
See Also Example
[image]

Initializes a new instance of the Resources class, based on Session identifier obtained from client already running existing MapGuide session.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal sessionId As String _
)
C#
public Resources(
string sessionId
)
C++
public:
Resources(
String sessionId
) sealed
J#
public Resources(
string sessionId
)
JScript
public function Resources(
sessionId : String
)

Parameters

sessionId
A Session identifier.

See Also

Resources Class
Resources Constructor Overload List


Properties

Resources Properties
[image]

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Maps | Returns MgMapCollection collection of objects containing MgMap instances found within underlying Repository.
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgResourceService service responsible for repository data management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

See Also

Resources Class


Maps Property

Resources.Maps Property
[image]

Returns MgMapCollection collection of objects containing MgMap instances found within underlying Repository.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Maps As MgMapCollection
C#
public MgMapCollection Maps { get; }
C++
public property MgMapCollection Maps sealed {
MgMapCollection get();
}
J#
/** property */
public MgMapCollection get_Maps();
JScript
public function get Maps() : MgMapCollection

Property Value

A MgMapCollection object.

Remarks

When the MgMap object is created, it is initialized with data from the map definition. As a user interacts with the map, the MgMap may change, but the map definition does not.

The map is saved in the session repository so it is available to all pages in the same session. You cannot save a map in the library repository.

See Also

Resources Class


Service Property

Resources.Service Property
[image]

Returns MgResourceService service responsible for repository data management.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Service As MgResourceService
C#
public MgResourceService Service { get; }
C++
public property MgResourceService Service sealed {
MgResourceService get();
}
J#
/** property */
public MgResourceService get_Service();
JScript
public function get Service() : MgResourceService

Property Value

A MgResourceService object.

Remarks

A service performs a particular set of MapGuide Server related functions. Resource service manages data in the repository.

See Also

Resources Class


Methods

Resources Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseLayerGroupNames | Returns array of strings containing base layer names found within given MgMap object. If there are no base layers found in map function returns empty array.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMapNameFromResource | Returns MapDefinition name for given resource name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Resources Class


Dispose Method

Resources.Dispose Method

Frees unmanaged resources referenced by this class.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden.
Public method | Dispose | Frees unmanaged resources referenced by this class. (inherited from Server)

See Also

Resources Class


Dispose Method (Boolean)

Resources.Dispose Method (Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

See Also

Resources Class
Resources.Dispose Overload List


GetBaseLayerGroupNames Method

Resources.GetBaseLayerGroupNames Method
[image]

Returns array of strings containing base layer names found within given MgMap object. If there are no base layers found in map function returns empty array.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBaseLayerGroupNames( _
ByVal map As MgMap _
) As String()
C#
public string[] GetBaseLayerGroupNames(
MgMap map
)
C++
public:
array<String>^ GetBaseLayerGroupNames(
MgMap map
) sealed
J#
public string[] GetBaseLayerGroupNames(
MgMap map
)
JScript
public function GetBaseLayerGroupNames(
map : MgMap
) : String[]

Parameters

map

See Also

Resources Class


GetMapNameFromResource Method

Resources.GetMapNameFromResource Method
[image]

Returns MapDefinition name for given resource name.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMapNameFromResource( _
ByVal resource As String _
) As String
C#
public string GetMapNameFromResource(
string resource
)
C++
public:
String GetMapNameFromResource(
String resource
) sealed
J#
public string GetMapNameFromResource(
string resource
)
JScript
public function GetMapNameFromResource(
resource : String
) : String

Parameters

resource
Name of the MgMap resource identifyer.

Return Value

Name of the MapDefinition.

See Also

Resources Class


Server Class

Server Class
See Also Example Members
[image]

Represents a base class for accessing MapGuide Server services and resources. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Server
Implements IDisposable
C#
public abstract class Server : IDisposable
C++
ref class Server abstract : IDisposable
J#
public class Server implements IDisposable
JScript
public class Server extends IDisposable

Remarks

Every instantiated class deriving from Server class shares common UserInformation, SiteConnection and Site objects. During single WebTier initialization call, it also creates common Session identifyer for derived classes.

If accessor classes get instantiated without session identifier, MgServerExtensions accesses MapGuide resources using library-based root resource name and credentials set within MgServerExtensions.Config file. This is very important, since such setup overrides existing MapGuide credentials.

Inheritance Hierarchy

System.Object
MgServerExtensions.Server
MgServerExtensions.Features
MgServerExtensions.Resources
MgServerExtensions.Tiling

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Server Members


Server Members

Server Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Represents a base class for accessing MapGuide Server services and resources. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Server.

Public Constructors

Name | Description
Server | Overloaded. Initializes a new instance of the Server class.
Top

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise.
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services.
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable.
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property.
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions.
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site.
Public property | UserInformation |
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Server | Overloaded. Initializes a new instance of the Server class.
Top

See Also

Server Class


Server Constructor

Server Constructor

Initializes a new instance of the Server class.

Overload List

 | Name | Description
Public method | Server | Initializes a new instance of the Server class.
Public method | Server (Server) | Initializes a new instance of the Server class, based on already instantiated object derived from Server class.
Public method | Server (String) | Initializes a new instance of the Server class, based on Session identifier obtained from client already running existing MapGuide session.

See Also

Server Class


Server Constructor ()

Server Constructor ()
See Also Example
[image]

Initializes a new instance of the Server class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Server()
C++
public:
Server() sealed
J#
public Server()
JScript
public function Server()

See Also

Server Class
Server Constructor Overload List


Server Constructor (Server)

Server Constructor (Server)
See Also Example
[image]

Initializes a new instance of the Server class, based on already instantiated object derived from Server class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal other As Server _
)
C#
public Server(
Server other
)
C++
public:
Server(
Server other
) sealed
J#
public Server(
Server other
)
JScript
public function Server(
other : Server
)

Parameters

other
Any object derived from Server class.

See Also

Server Class
Server Constructor Overload List


Server Constructor (String)

Server Constructor (String)
See Also Example
[image]

Initializes a new instance of the Server class, based on Session identifier obtained from client already running existing MapGuide session.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal sessionId As String _
)
C#
public Server(
string sessionId
)
C++
public:
Server(
String sessionId
) sealed
J#
public Server(
string sessionId
)
JScript
public function Server(
sessionId : String
)

Parameters

sessionId
A Session identifier.

See Also

Server Class
Server Constructor Overload List


Properties

Server Properties
[image]

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise.
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services.
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable.
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property.
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions.
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site.
Public property | UserInformation |
Top

See Also

Server Class


IsClientInitiatedSession Property

Server.IsClientInitiatedSession Property
[image]

Returns True if obtained Session identifier was originally issued to the client, False otherwise.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClientInitiatedSession As Boolean
C#
public bool IsClientInitiatedSession { get; }
C++
public property bool IsClientInitiatedSession sealed {
bool get();
}
J#
/** property */
public bool get_IsClientInitiatedSession();
JScript
public function get IsClientInitiatedSession() : bool

See Also

Server Class


Latency Property

Server.Latency Property
[image]

Latency in miliseconds required by certain operations interacting with MapGuide Server services.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Property Latency As Integer
C#
public int Latency { get; set; }
C++
public property int Latency sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Latency();

/** property */
public void set_Latency(int value);
JScript
public function get Latency() : int

public function set Latency(value : int);

Property Value

Latency time in miliseconds.

Remarks

Default value is 100 miliseconds. If too small or zero, some operations may cause MapGuide Server to hang indefinately.

See Also

Server Class


MapAgentURL Property

Server.MapAgentURL Property
[image]

Returns URL of the MapGuide Server's MapAgent executable.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapAgentURL As String
C#
public string MapAgentURL { get; }
C++
public property string MapAgentURL sealed {
String get();
}
J#
/** property */
public string get_MapAgentURL();
JScript
public function get MapAgentURL() : String

Remarks

This value can be set within MgServerExtensions.config file.

See Also

Server Class


Repository Property

Server.Repository Property
[image]

Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Repository As String
C#
public string Repository { get; }
C++
public property string Repository sealed {
String get();
}
J#
/** property */
public string get_Repository();
JScript
public function get Repository() : String

Property Value

For library-based repository, root resource name can be set within MgServerExtensions.Config file.

See Also

Server Class


Session Property

Server.Session Property
[image]

Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Session As String
C#
public string Session { get; }
C++
public property string Session sealed {
String get();
}
J#
/** property */
public string get_Session();
JScript
public function get Session() : String

Property Value

Session identifier string.

Remarks

Each session has its own Repository, which stores the run-time map state. It can also be used to store other data, like temporary layers that apply only to an individual session. Data in a session repository is destroyed when the session ends.

A resource identifier for a resource in the library will always begin with Library://. For example:

Library://Samples/Layouts/SamplesPhp.WebLayout.

A resource identifier for a session resource will always begin with Session:, followed by the session id. For example:

Session:70ea89fe-0000-1000-8000-005056c00008_en//layer.LayerDefinition.

See Also

Server Class
IsClientInitiatedSession


Site Property

Server.Site Property
[image]

Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As MgSite
C#
public MgSite Site { get; }
C++
public property MgSite Site sealed {
MgSite get();
}
J#
/** property */
public MgSite get_Site();
JScript
public function get Site() : MgSite

Property Value

A MgSite object.

See Also

Server Class


SiteConnection Property

Server.SiteConnection Property
[image]

Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteConnection As MgSiteConnection
C#
public MgSiteConnection SiteConnection { get; }
C++
public property MgSiteConnection SiteConnection sealed {
MgSiteConnection get();
}
J#
/** property */
public MgSiteConnection get_SiteConnection();
JScript
public function get SiteConnection() : MgSiteConnection

Property Value

A MgSiteConnection object.

See Also

Server Class


UserInformation Property

Server.UserInformation Property
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserInformation As MgUserInformation
C#
public MgUserInformation UserInformation { get; }
C++
public property MgUserInformation UserInformation sealed {
MgUserInformation get();
}
J#
/** property */
public MgUserInformation get_UserInformation();
JScript
public function get UserInformation() : MgUserInformation

See Also

Server Class


Methods

Server Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Server Class


Dispose Method

Server.Dispose Method

Frees unmanaged resources referenced by this class.

Overload List

 | Name | Description
Public method | Dispose | Frees unmanaged resources referenced by this class.
Family method | Dispose (Boolean) |

See Also

Server Class


Dispose Method ()

Server.Dispose Method ()
See Also Example
[image]

Frees unmanaged resources referenced by this class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

Server Class
Server.Dispose Overload List


Dispose Method (Boolean)

Server.Dispose Method (Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

See Also

Server Class
Server.Dispose Overload List


RestartServer Method

Server.RestartServer Method
[image]

Stops, then restarts MapGuide Server process.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub RestartServer()
C#
public void RestartServer()
C++
public:
void RestartServer() sealed
J#
public void RestartServer()
JScript
public function RestartServer()

Remarks

Exact MapGuide Server process name can be set within MgServerExtensions.config file. When server gets restarted, existing SiteConnection also gets reinstantiated (including Session identifier).

See Also

Server Class


SpatialOperations Enumeration

SpatialOperations Enumeration
[image]

Enumerates methods to test spatial relationships.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Enum SpatialOperations
C#
public enum SpatialOperations
C++
public enum class SpatialOperations
J#
public enum SpatialOperations
JScript
public enum SpatialOperations

Members

Member Name | Description
Contains | Test whether the geometric property value spatially contains the literal geometric value.
Crosses |
Disjoint |
Equals |
Intersects |
Overlaps |
Touches |
Within |
CoveredBy |
Inside |
EnvelopeIntersects |

See Also


Tiling Class

Tiling Class
See Also Example Members
[image]

Class responsible for rendering maps into images. It also supports generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class Tiling
Inherits Server
C#
public class Tiling : Server
C++
ref class Tiling : Server
J#
public class Tiling extends Server
JScript
public class Tiling extends Server

Remarks

Tile caching for a map is possible only if it contains base layers. Base layers are stored within base layer groups. Enumerated list of map's base layer groups is accessible via GetBaseLayerGroupNames.

Inheritance Hierarchy

System.Object
MgServerExtensions.Server
MgServerExtensions.Tiling

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Tiling Members


Tiling Members

Tiling Members
See Also Example Properties Methods Events Explicit Inteface Implementations
[image]

Class responsible for rendering maps into images. It also supports generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer.

The following tables list the members exposed by Tiling.

Public Constructors

Name | Description
Tiling | Overloaded. Initializes a new instance of the Tiling class.
Top

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgTileService service responsible for tile cache management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

Public Methods

 | Name | Description
Public method | ClearCache | Overloaded. Clears existing tile cache of any MgMap object found within Repository. See method overloads for erasing specific MgMap tile cache.
Public method | CreateCache | Overloaded. Creates tile cache for every MgMap's base layer group, on every finite scale range found within underlying Repository. See method overloads for pre-rendering of specific maps, groups or scales.
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | AfterGetTile | Occurs after each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes AfterGetTileEventArgs containing details on possible exceptions raised during map tile processing.
Public event | BeforeGetTile | Occurs before each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes BeforeGetTileEventArgs containing details on map tile about to be processed.
Top

Explicit Interface Implementations

Name | Description
Tiling | Overloaded. Initializes a new instance of the Tiling class.
Top

See Also

Tiling Class


Tiling Constructor

Tiling Constructor

Initializes a new instance of the Tiling class.

Overload List

 | Name | Description
Public method | Tiling | Initializes a new instance of the Tiling class.
Public method | Tiling (Server) | Initializes a new instance of the Tiling class, based on already instantiated object derived from Server class.
Public method | Tiling (String) | Initializes a new instance of the Tiling class, based on Session identifier obtained from client already running existing MapGuide session.

See Also

Tiling Class


Tiling Constructor ()

Tiling Constructor ()
See Also Example
[image]

Initializes a new instance of the Tiling class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Tiling()
C++
public:
Tiling() sealed
J#
public Tiling()
JScript
public function Tiling()

See Also

Tiling Class
Tiling Constructor Overload List


Tiling Constructor (Server)

Tiling Constructor (Server)
See Also Example
[image]

Initializes a new instance of the Tiling class, based on already instantiated object derived from Server class.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal other As Server _
)
C#
public Tiling(
Server other
)
C++
public:
Tiling(
Server other
) sealed
J#
public Tiling(
Server other
)
JScript
public function Tiling(
other : Server
)

Parameters

other
Any object derived from Server class.

See Also

Tiling Class
Tiling Constructor Overload List


Tiling Constructor (String)

Tiling Constructor (String)
See Also Example
[image]

Initializes a new instance of the Tiling class, based on Session identifier obtained from client already running existing MapGuide session.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal sessionId As String _
)
C#
public Tiling(
string sessionId
)
C++
public:
Tiling(
String sessionId
) sealed
J#
public Tiling(
string sessionId
)
JScript
public function Tiling(
sessionId : String
)

Parameters

sessionId
A Session identifier.

See Also

Tiling Class
Tiling Constructor Overload List


Properties

Tiling Properties
[image]

Public Properties

 | Name | Description
Public property | IsClientInitiatedSession | Returns True if obtained Session identifier was originally issued to the client, False otherwise. (inherited from Server)
Public property | Latency | Latency in miliseconds required by certain operations interacting with MapGuide Server services. (inherited from Server)
Public property | MapAgentURL | Returns URL of the MapGuide Server's MapAgent executable. (inherited from Server)
Public property | Repository | Returns resource name (path) of the underlying library or Session repository, depending on the class constructor parameters. (inherited from Server)
Public property | Service | Returns MgTileService service responsible for tile cache management.
Public property | Session | Returns current session identifier. Sessions may get instantiated internally, or by client. For exact session originator see IsClientInitiatedSession property. (inherited from Server)
Public property | Site | Returns MgSite object based on UserInformation credentials. The MgSite class contains methods which allow access to basic site-related functionality: enumerate users, enumerate groups, create and destroy user sessions. (inherited from Server)
Public property | SiteConnection | Returns MgSiteConnection object based on UserInformation credentials. Site connection provides basic authentication and service access capabilities for the site. (inherited from Server)
Public property | UserInformation | (inherited from Server)
Top

See Also

Tiling Class


Service Property

Tiling.Service Property
[image]

Returns MgTileService service responsible for tile cache management.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Service As MgTileService
C#
public MgTileService Service { get; }
C++
public property MgTileService Service sealed {
MgTileService get();
}
J#
/** property */
public MgTileService get_Service();
JScript
public function get Service() : MgTileService

Property Value

A MgTileService service.

See Also

Tiling Class


Methods

Tiling Methods
[image]

Public Methods

 | Name | Description
Public method | ClearCache | Overloaded. Clears existing tile cache of any MgMap object found within Repository. See method overloads for erasing specific MgMap tile cache.
Public method | CreateCache | Overloaded. Creates tile cache for every MgMap's base layer group, on every finite scale range found within underlying Repository. See method overloads for pre-rendering of specific maps, groups or scales.
Public method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RestartServer | Stops, then restarts MapGuide Server process. (inherited from Server)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Frees unmanaged resources referenced by this class.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Tiling Class


ClearCache Method

Tiling.ClearCache Method

Clears existing tile cache of any MgMap object found within Repository. See method overloads for erasing specific MgMap tile cache.

Overload List

 | Name | Description
Public method | ClearCache | Clears existing tile cache of any MgMap object found within Repository. See method overloads for erasing specific MgMap tile cache.
Public method | ClearCache (MgMap) | Clears existing tile cache found within given MgMap's repository.
Public method | ClearCache (String) | Clears existing tile cache found within named MgMap's repository. Parameter is the name of the map.

See Also

Tiling Class


ClearCache Method ()

Tiling.ClearCache Method ()
See Also Example
[image]

Clears existing tile cache of any MgMap object found within Repository. See method overloads for erasing specific MgMap tile cache.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearCache()
C#
public void ClearCache()
C++
public:
void ClearCache() sealed
J#
public void ClearCache()
JScript
public function ClearCache()

See Also

Tiling Class
Tiling.ClearCache Overload List


ClearCache Method (MgMap)

Tiling.ClearCache Method (MgMap)
See Also Example
[image]

Clears existing tile cache found within given MgMap's repository.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearCache( _
ByVal map As MgMap _
)
C#
public void ClearCache(
MgMap map
)
C++
public:
void ClearCache(
MgMap map
) sealed
J#
public void ClearCache(
MgMap map
)
JScript
public function ClearCache(
map : MgMap
)

Parameters

map
MgMap object

See Also

Tiling Class
Tiling.ClearCache Overload List


ClearCache Method (String)

Tiling.ClearCache Method (String)
See Also Example
[image]

Clears existing tile cache found within named MgMap's repository. Parameter is the name of the map.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearCache( _
ByVal mapName As String _
)
C#
public void ClearCache(
string mapName
)
C++
public:
void ClearCache(
String mapName
) sealed
J#
public void ClearCache(
string mapName
)
JScript
public function ClearCache(
mapName : String
)

Parameters

mapName
Name of the MgMap object

See Also

Tiling Class
Tiling.ClearCache Overload List


CreateCache Method

Tiling.CreateCache Method

Creates tile cache for every MgMap's base layer group, on every finite scale range found within underlying Repository. See method overloads for pre-rendering of specific maps, groups or scales.

Overload List

 | Name | Description
Public method | CreateCache | Creates tile cache for every MgMap's base layer group, on every finite scale range found within underlying Repository. See method overloads for pre-rendering of specific maps, groups or scales.
Public method | CreateCache (MgMap, String, Double, Int32, Int32) | Creates tile cache for named base layer group within given MgMap object, using given finite scale (not scale index).
Public method | CreateCache (String) | Creates tile cache for every named map's base layer group, on every scale range found within underlying Repository.
Public method | CreateCache (String, String) | Creates tile cache for named base layer group within named map, using full finite scale range.
Public method | CreateCache (String, String, Double, Int32, Int32) | Creates tile cache for named base layer group within named map, using given finite scale (not scale index).

See Also

Tiling Class


CreateCache Method ()

Tiling.CreateCache Method ()
See Also Example
[image]

Creates tile cache for every MgMap's base layer group, on every finite scale range found within underlying Repository. See method overloads for pre-rendering of specific maps, groups or scales.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCache()
C#
public void CreateCache()
C++
public:
void CreateCache() sealed
J#
public void CreateCache()
JScript
public function CreateCache()

Remarks

Event occuring before processing of each tileEvent occuring after each tile gets processedErasing existing tile cache from repository

See Also

Tiling Class
MgServerExtensions Namespace
Tiling.CreateCache Overload List
Event occuring before processing of each tile
Event occuring after each tile gets processed
Erasing existing tile cache from repository


CreateCache Method (MgMap, String, Double, Int32, Int32)

Tiling.CreateCache Method (MgMap, String, Double, Int32, Int32)
See Also Example
[image]

Creates tile cache for named base layer group within given MgMap object, using given finite scale (not scale index).

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCache( _
ByVal map As MgMap, _
ByVal group As String, _
ByVal scale As Double, _
ByVal fromTileColumn As Integer, _
ByVal fromTileRow As Integer _
)
C#
public void CreateCache(
MgMap map,
string group,
double scale,
int fromTileColumn,
int fromTileRow
)
C++
public:
void CreateCache(
MgMap map,
String group,
double scale,
int fromTileColumn,
int fromTileRow
) sealed
J#
public void CreateCache(
MgMap map,
string group,
double scale,
int fromTileColumn,
int fromTileRow
)
JScript
public function CreateCache(
map : MgMap,
group : String,
scale : double,
fromTileColumn : int,
fromTileRow : int
)

Parameters

map
A MgMap object.
group
Name of the base layer group.
scale
Map's finite scale.
fromTileColumn
Beginning tile column index.
fromTileRow
Beginning tile row index.

Remarks

Event occuring before processing of each tileEvent occuring after each tile gets processedErasing existing tile cache from repository

See Also

Tiling Class
MgServerExtensions Namespace
Tiling.CreateCache Overload List
Event occuring before processing of each tile
Event occuring after each tile gets processed
Erasing existing tile cache from repository


CreateCache Method (String)

Tiling.CreateCache Method (String)
See Also Example
[image]

Creates tile cache for every named map's base layer group, on every scale range found within underlying Repository.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCache( _
ByVal mapName As String _
)
C#
public void CreateCache(
string mapName
)
C++
public:
void CreateCache(
String mapName
) sealed
J#
public void CreateCache(
string mapName
)
JScript
public function CreateCache(
mapName : String
)

Parameters

mapName
Name of the map.

Remarks

Event occuring before processing of each tileEvent occuring after each tile gets processedErasing existing tile cache from repository

See Also

Tiling Class
MgServerExtensions Namespace
Tiling.CreateCache Overload List
Event occuring before processing of each tile
Event occuring after each tile gets processed
Erasing existing tile cache from repository


CreateCache Method (String, String)

Tiling.CreateCache Method (String, String)
See Also Example
[image]

Creates tile cache for named base layer group within named map, using full finite scale range.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCache( _
ByVal mapName As String, _
ByVal group As String _
)
C#
public void CreateCache(
string mapName,
string group
)
C++
public:
void CreateCache(
String mapName,
String group
) sealed
J#
public void CreateCache(
string mapName,
string group
)
JScript
public function CreateCache(
mapName : String,
group : String
)

Parameters

mapName
Name of the map.
group
Name of the base layer group.

Remarks

Event occuring before processing of each tileEvent occuring after each tile gets processedErasing existing tile cache from repository

See Also

Tiling Class
MgServerExtensions Namespace
Tiling.CreateCache Overload List
Event occuring before processing of each tile
Event occuring after each tile gets processed
Erasing existing tile cache from repository


CreateCache Method (String, String, Double, Int32, Int32)

Tiling.CreateCache Method (String, String, Double, Int32, Int32)
See Also Example
[image]

Creates tile cache for named base layer group within named map, using given finite scale (not scale index).

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCache( _
ByVal mapName As String, _
ByVal group As String, _
ByVal scale As Double, _
ByVal fromTileColumn As Integer, _
ByVal fromTileRow As Integer _
)
C#
public void CreateCache(
string mapName,
string group,
double scale,
int fromTileColumn,
int fromTileRow
)
C++
public:
void CreateCache(
String mapName,
String group,
double scale,
int fromTileColumn,
int fromTileRow
) sealed
J#
public void CreateCache(
string mapName,
string group,
double scale,
int fromTileColumn,
int fromTileRow
)
JScript
public function CreateCache(
mapName : String,
group : String,
scale : double,
fromTileColumn : int,
fromTileRow : int
)

Parameters

mapName
Name of the map.
group
Name of the base layer group.
scale
Map's finite scale.
fromTileColumn
Beginning tile column index.
fromTileRow
Beginning tile row index.

Remarks

Event occuring before processing of each tileEvent occuring after each tile gets processedErasing existing tile cache from repository

See Also

Tiling Class
MgServerExtensions Namespace
Tiling.CreateCache Overload List
Event occuring before processing of each tile
Event occuring after each tile gets processed
Erasing existing tile cache from repository


Dispose Method

Tiling.Dispose Method

Frees unmanaged resources referenced by this class.

Overload List

 | Name | Description
Public method | Dispose | Frees unmanaged resources referenced by this class. (inherited from Server)
Family method | Dispose (Boolean) | Overridden.

See Also

Tiling Class


Dispose Method (Boolean)

Tiling.Dispose Method (Boolean)
See Also Example
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

See Also

Tiling Class
Tiling.Dispose Overload List


Events

Tiling Events
[image]

Public Events

 | Name | Description
Public event | AfterGetTile | Occurs after each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes AfterGetTileEventArgs containing details on possible exceptions raised during map tile processing.
Public event | BeforeGetTile | Occurs before each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes BeforeGetTileEventArgs containing details on map tile about to be processed.
Top

See Also

Tiling Class


AfterGetTile Event

Tiling.AfterGetTile Event
[image]

Occurs after each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes AfterGetTileEventArgs containing details on possible exceptions raised during map tile processing.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Event AfterGetTile As Tiling.AfterGetTileEventHandler
C#
public event Tiling.AfterGetTileEventHandler AfterGetTile
C++
public:
virtual event Tiling.AfterGetTileEventHandler AfterGetTile {
void add(Tiling.AfterGetTileEventHandler value) sealed ;
void remove(Tiling.AfterGetTileEventHandler value) sealed ;
}
J#
/** event */
public final void add_AfterGetTile(Tiling.AfterGetTileEventHandler value);

/** event */
public final void remove_AfterGetTile(Tiling.AfterGetTileEventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

Creating tile cache repository

See Also

Tiling Class
Creating tile cache repository


BeforeGetTile Event

Tiling.BeforeGetTile Event
[image]

Occurs before each call to GetTile function within batch tiling operation being run via CreateCache method. Event also exposes BeforeGetTileEventArgs containing details on map tile about to be processed.

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Event BeforeGetTile As Tiling.BeforeGetTileEventHandler
C#
public event Tiling.BeforeGetTileEventHandler BeforeGetTile
C++
public:
virtual event Tiling.BeforeGetTileEventHandler BeforeGetTile {
void add(Tiling.BeforeGetTileEventHandler value) sealed ;
void remove(Tiling.BeforeGetTileEventHandler value) sealed ;
}
J#
/** event */
public final void add_BeforeGetTile(Tiling.BeforeGetTileEventHandler value);

/** event */
public final void remove_BeforeGetTile(Tiling.BeforeGetTileEventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

Creating tile cache repository

See Also

Tiling Class
Creating tile cache repository


Tiling.AfterGetTileEventHandler Delegate

Tiling.AfterGetTileEventHandler Delegate
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Tiling.AfterGetTileEventHandler( _
ByVal sender As Object, _
ByRef e As AfterGetTileEventArgs _
)
C#
public delegate void Tiling.AfterGetTileEventHandler(
object sender,
ref AfterGetTileEventArgs e
)
C++
public delegate void Tiling.AfterGetTileEventHandler(
Object sender,
AfterGetTileEventArgs% e
)
J#
/** delegate */
public delegate void Tiling.AfterGetTileEventHandler(
object sender,
AfterGetTileEventArgs e
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also


Tiling.BeforeGetTileEventHandler Delegate

Tiling.BeforeGetTileEventHandler Delegate
[image]

Namespace: MgServerExtensions
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Tiling.BeforeGetTileEventHandler( _
ByVal sender As Object, _
ByRef e As BeforeGetTileEventArgs _
)
C#
public delegate void Tiling.BeforeGetTileEventHandler(
object sender,
ref BeforeGetTileEventArgs e
)
C++
public delegate void Tiling.BeforeGetTileEventHandler(
Object sender,
BeforeGetTileEventArgs% e
)
J#
/** delegate */
public delegate void Tiling.BeforeGetTileEventHandler(
object sender,
BeforeGetTileEventArgs e
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also


MgServerExtensions.WebServices

MgServerExtensions.WebServices Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | FeatureService | Web service responsible for feature repository data management. This service is based on Features class.
Public class | TilingService | Web service responsible for rendering maps into images, supporting generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer. This service is based on Tiling class.


FeatureService Class

FeatureService Class
See Also Example Members
[image]

Web service responsible for feature repository data management. This service is based on Features class.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureService
Inherits WebService
C#
public class FeatureService : WebService
C++
ref class FeatureService : WebService
J#
public class FeatureService extends WebService
JScript
public class FeatureService extends WebService

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Web.Services.WebService
MgServerExtensions.WebServices.FeatureService

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureService Members
MgServerExtensions.WebServices Namespace


FeatureService Members

FeatureService Members
See Also Example Constructors Properties Methods Events
[image]

Web service responsible for feature repository data management. This service is based on Features class.

The following tables list the members exposed by FeatureService.

Public Constructors

 | Name | Description
Public method | FeatureService | Initializes a new instance of the FeatureService class.
Top

Public Properties

 | Name | Description
Public property | Application | Gets the application object for the current HTTP request. (inherited from WebService)
Public property | Container | Gets the container for the component. (inherited from MarshalByValueComponent)
Public property | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (inherited from WebService)
Public property | DesignMode | Gets a value indicating whether the component is currently in design mode. (inherited from MarshalByValueComponent)
Public property | Server | Gets the HttpServerUtility for the current request. (inherited from WebService)
Public property | Session | Gets the HttpSessionState instance for the current request. (inherited from WebService)
Public property | Site | Gets or sets the site of the component. (inherited from MarshalByValueComponent)
Public property | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (inherited from WebService)
Public property | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (inherited from WebService)
Top

Protected Properties

 | Name | Description
Family property | Events | Gets the list of event handlers that are attached to this component. (inherited from MarshalByValueComponent)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetNearestCoordinate |
Public method | GetService | Gets the implementer of the IServiceProvider. (inherited from MarshalByValueComponent)
Public method | GetStringProperty | Returns one dimensional array of strings based on given feature source, feature class and property name. Similar to SQL SELECT command. If no matching values were found, returns empty array.
Public method | GetStringPropertyFiltered | Returns one dimensional array of strings based on given feature source, feature class, property name and property filter. Similar to SQL SELECT...WHERE command. If no matching values were found, returns empty array.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from MarshalByValueComponent)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Family method | Finalize | (inherited from MarshalByValueComponent)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from MarshalByValueComponent)
Top

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


FeatureService Constructor

FeatureService Constructor
[image]

Initializes a new instance of the FeatureService class.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureService()
C++
public:
FeatureService() sealed
J#
public FeatureService()
JScript
public function FeatureService()

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


Methods

FeatureService Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetNearestCoordinate |
Public method | GetService | Gets the implementer of the IServiceProvider. (inherited from MarshalByValueComponent)
Public method | GetStringProperty | Returns one dimensional array of strings based on given feature source, feature class and property name. Similar to SQL SELECT command. If no matching values were found, returns empty array.
Public method | GetStringPropertyFiltered | Returns one dimensional array of strings based on given feature source, feature class, property name and property filter. Similar to SQL SELECT...WHERE command. If no matching values were found, returns empty array.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from MarshalByValueComponent)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Family method | Finalize | (inherited from MarshalByValueComponent)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


GetNearestCoordinate Method

FeatureService.GetNearestCoordinate Method
[image]

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNearestCoordinate( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal geometricPropertyName As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal maxOffset As Double _
) As Double()
C#
public double[] GetNearestCoordinate(
string featureSourceName,
string className,
string geometricPropertyName,
double x,
double y,
double maxOffset
)
C++
public:
array<double>^ GetNearestCoordinate(
String featureSourceName,
String className,
String geometricPropertyName,
double x,
double y,
double maxOffset
) sealed
J#
public double[] GetNearestCoordinate(
string featureSourceName,
string className,
string geometricPropertyName,
double x,
double y,
double maxOffset
)
JScript
public function GetNearestCoordinate(
featureSourceName : String,
className : String,
geometricPropertyName : String,
x : double,
y : double,
maxOffset : double
) : double[]

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


GetStringProperty Method

FeatureService.GetStringProperty Method
[image]

Returns one dimensional array of strings based on given feature source, feature class and property name. Similar to SQL SELECT command. If no matching values were found, returns empty array.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStringProperty( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal propertyName As String, _
ByVal isGrouped As Boolean, _
ByVal isOrdered As Boolean _
) As String()
C#
public string[] GetStringProperty(
string featureSourceName,
string className,
string propertyName,
bool isGrouped,
bool isOrdered
)
C++
public:
array<String>^ GetStringProperty(
String featureSourceName,
String className,
String propertyName,
bool isGrouped,
bool isOrdered
) sealed
J#
public string[] GetStringProperty(
string featureSourceName,
string className,
string propertyName,
bool isGrouped,
bool isOrdered
)
JScript
public function GetStringProperty(
featureSourceName : String,
className : String,
propertyName : String,
isGrouped : bool,
isOrdered : bool
) : String[]

Parameters

featureSourceName
FeatureSource name.
className
Feature Class name.
propertyName
Name of the string-based property.
isGrouped
If True groups resulting values. Similar to SQL GROUPBY command.
isOrdered
If True, sorts resulting values in ascending order. Similar to SQL ORDER ASCENDING command.

Return Value

One dimensional array of strings.

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


GetStringPropertyFiltered Method

FeatureService.GetStringPropertyFiltered Method
[image]

Returns one dimensional array of strings based on given feature source, feature class, property name and property filter. Similar to SQL SELECT...WHERE command. If no matching values were found, returns empty array.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStringPropertyFiltered( _
ByVal featureSourceName As String, _
ByVal className As String, _
ByVal propertyName As String, _
ByVal valueFilter As String, _
ByVal isGrouped As Boolean, _
ByVal isOrdered As Boolean _
) As String()
C#
public string[] GetStringPropertyFiltered(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
bool isGrouped,
bool isOrdered
)
C++
public:
array<String>^ GetStringPropertyFiltered(
String featureSourceName,
String className,
String propertyName,
String valueFilter,
bool isGrouped,
bool isOrdered
) sealed
J#
public string[] GetStringPropertyFiltered(
string featureSourceName,
string className,
string propertyName,
string valueFilter,
bool isGrouped,
bool isOrdered
)
JScript
public function GetStringPropertyFiltered(
featureSourceName : String,
className : String,
propertyName : String,
valueFilter : String,
isGrouped : bool,
isOrdered : bool
) : String[]

Parameters

featureSourceName
FeatureSource name.
className
Feature Class name.
propertyName
Name of the string-based property.
valueFilter
Property value filter expression applied to given feature class.
isGrouped
If True groups resulting values. Similar to SQL GROUPBY command.
isOrdered
If True, sorts resulting values in ascending order. Similar to SQL ORDER ASCENDING command.

Return Value

One dimensional array of strings.

See Also

FeatureService Class
MgServerExtensions.WebServices Namespace


TilingService Class

TilingService Class
See Also Example Members
[image]

Web service responsible for rendering maps into images, supporting generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer. This service is based on Tiling class.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Class TilingService
Inherits WebService
C#
public class TilingService : WebService
C++
ref class TilingService : WebService
J#
public class TilingService extends WebService
JScript
public class TilingService extends WebService

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Web.Services.WebService
MgServerExtensions.WebServices.TilingService

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TilingService Members
MgServerExtensions.WebServices Namespace


TilingService Members

TilingService Members
See Also Example Constructors Properties Methods Events
[image]

Web service responsible for rendering maps into images, supporting generating pre-rendered tile cache for smooth pans and zooms in the AJAX Viewer. This service is based on Tiling class.

The following tables list the members exposed by TilingService.

Public Constructors

 | Name | Description
Public method | TilingService | Initializes a new instance of the TilingService class.
Top

Public Properties

 | Name | Description
Public property | Application | Gets the application object for the current HTTP request. (inherited from WebService)
Public property | Container | Gets the container for the component. (inherited from MarshalByValueComponent)
Public property | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (inherited from WebService)
Public property | DesignMode | Gets a value indicating whether the component is currently in design mode. (inherited from MarshalByValueComponent)
Public property | Server | Gets the HttpServerUtility for the current request. (inherited from WebService)
Public property | Session | Gets the HttpSessionState instance for the current request. (inherited from WebService)
Public property | Site | Gets or sets the site of the component. (inherited from MarshalByValueComponent)
Public property | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (inherited from WebService)
Public property | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (inherited from WebService)
Top

Protected Properties

 | Name | Description
Family property | Events | Gets the list of event handlers that are attached to this component. (inherited from MarshalByValueComponent)
Top

Public Methods

 | Name | Description
Public method | ClearCache | See ClearCache for more info.
Public method | ClearCacheForMap | See ClearCache for more info.
Public method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets the implementer of the IServiceProvider. (inherited from MarshalByValueComponent)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from MarshalByValueComponent)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Family method | Finalize | (inherited from MarshalByValueComponent)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from MarshalByValueComponent)
Top

See Also

TilingService Class
MgServerExtensions.WebServices Namespace


TilingService Constructor

TilingService Constructor
[image]

Initializes a new instance of the TilingService class.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TilingService()
C++
public:
TilingService() sealed
J#
public TilingService()
JScript
public function TilingService()

See Also

TilingService Class
MgServerExtensions.WebServices Namespace


Methods

TilingService Methods
[image]

Public Methods

 | Name | Description
Public method | ClearCache | See ClearCache for more info.
Public method | ClearCacheForMap | See ClearCache for more info.
Public method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets the implementer of the IServiceProvider. (inherited from MarshalByValueComponent)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from MarshalByValueComponent)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases the resources used by the MarshalByValueComponent. (inherited from MarshalByValueComponent)
Family method | Finalize | (inherited from MarshalByValueComponent)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TilingService Class
MgServerExtensions.WebServices Namespace


ClearCache Method

TilingService.ClearCache Method
[image]

See ClearCache for more info.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearCache() As Boolean
C#
public bool ClearCache()
C++
public:
bool ClearCache() sealed
J#
public bool ClearCache()
JScript
public function ClearCache() : bool

See Also

TilingService Class
MgServerExtensions.WebServices Namespace


ClearCacheForMap Method

TilingService.ClearCacheForMap Method
[image]

See ClearCache for more info.

Namespace: MgServerExtensions.WebServices
Assembly: MgServerExtensions (in MgServerExtensions.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearCacheForMap( _
ByVal mapName As String _
) As Boolean
C#
public bool ClearCacheForMap(
string mapName
)
C++
public:
bool ClearCacheForMap(
String mapName
) sealed
J#
public bool ClearCacheForMap(
string mapName
)
JScript
public function ClearCacheForMap(
mapName : String
) : bool

Parameters

mapName
Name of the map.

See Also

TilingService Class
MgServerExtensions.WebServices Namespace


MgServerExtensions Hierarchy

MgServerExtensions Hierarchy
System.Object
MgServerExtensions.DocumentField
MgServerExtensions.Documents
MgServerExtensions.Server ---- System.IDisposable
MgServerExtensions.Features
MgServerExtensions.Resources
MgServerExtensions.Tiling
System.Collections.ObjectModel.Collection<T> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IEnumerable<T>, System.Collections.Generic.IList<T>, System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
MgServerExtensions.DocumentFields
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
MgServerExtensions.Tiling.AfterGetTileEventHandler
MgServerExtensions.Tiling.BeforeGetTileEventHandler
System.EventArgs
MgServerExtensions.AfterGetTileEventArgs
MgServerExtensions.BeforeGetTileEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MgServerExtensions.GeometryTypes
MgServerExtensions.SpatialOperations

See Also


MgServerExtensions.WebServices Hierarchy

MgServerExtensions.WebServices Hierarchy
System.Object
System.ComponentModel.MarshalByValueComponent ---- System.ComponentModel.IComponent, System.IDisposable, System.IServiceProvider
System.Web.Services.WebService
MgServerExtensions.WebServices.FeatureService
MgServerExtensions.WebServices.TilingService

See Also

MgServerExtensions.WebServices Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace